Compatibility with old-time for the time package

no issues!

there don't seem to be any issues for this project.