up-to-date mirror of the official darcs screened branch on darcs.net (fork of darcs's darcs-reviewed) (http://darcs.net/Development/GettingStarted)

resolve issue2367: rename amend-record to amend, make --unrecord more visible

also rename amend flag --add to --record

ghThu Apr 10 16:49:24 UTC 2014

resolve issue1987: Garbage collection for inventories and patches.

mdiazWed Apr 9 22:30:09 UTC 2014

Accept issue1987: regression tests for garbage collection for

inventories and patches.

mdiazWed Apr 9 01:12:18 UTC 2014

fix warning in Record

ghTue Apr 8 19:13:04 UTC 2014

Resolve Issue1416: put log files in tempdir instead of in working dir.

The temporary files are found in darcs. For the commands amend-record, record and tag, the temp file is patchdescription.txt and is persistent, ie always have the last message whether failed or not the command. For send, we use two files, darcs-send for the editing and darcs-send.final for the backup. If all is ok, the files are removed.

alegadeaTue Apr 8 16:45:28 UTC 2014

Accept issue2365: whatsnew fails in repos made w get --no-working-dir

ghSun Mar 30 18:19:49 UTC 2014

polish help string on get --set-strings-executable

ghTue Mar 25 15:13:48 UTC 2014

Resolve Issue2263: Option --set-scripts-executable is not properly documented

alegadeaSat Mar 22 23:21:56 UTC 2014

eliminate withRepoReadLock obsolete since old-fashioned deprecation

ghMon Mar 17 01:58:44 UTC 2014

conditionally use local copy of Data.Map.Strict in Darcs.Repository.Util

This is needed for building with containers<0.5, e.g. on Debian stable

ganeshSun Mar 16 14:47:49 UTC 2014

pandoc-ize README and remove mention of old flags and warnings

ghSun Mar 2 18:52:17 UTC 2014

resolve issue2357: switching to regex-compat-tdfa for unicode support

co-danFri Feb 14 12:54:59 UTC 2014

A shell test for `whatsnew --interactive`

co-danSat Feb 8 14:11:37 UTC 2014

hashed-storage: GHC 7.8 build fix

ganeshSat Feb 8 11:57:47 UTC 2014

support GHC 7.8 and various assorted other version bumps

The MAPI symbol change seems to be needed for the new gcc

ganeshSat Feb 8 10:37:09 UTC 2014

resolve issue851: interactive mode for whatsnew

co-danFri Feb 7 11:00:51 UTC 2014

Cleaning up the headers in WhatsNew and SelectChanges

co-danFri Feb 7 10:59:11 UTC 2014

drop support for GHC 7.0/7.2

ganeshFri Feb 7 20:21:57 UTC 2014

get rid of now redundant conditionalisation

ganeshFri Feb 7 20:22:01 UTC 2014

remove accidentally added file

ganeshFri Feb 7 06:21:05 UTC 2014

fix hashed-storage build on Windows

ganeshFri Feb 7 07:49:13 UTC 2014

we need utf8-string on Windows too now for the fast-export/import code

ganeshFri Feb 7 19:29:23 UTC 2014

bump cryptohash dependency

ganeshThu Jan 2 20:41:17 UTC 2014

Making sure darcs builds on OSX Mavericks

co-danSun Jan 26 16:30:54 UTC 2014

resolve issue2332: ignore case of characters in prompt

ghTue Jan 28 20:16:57 UTC 2014

Implement convert --export and --import for git conversion

Port of code by Petr Rockai and Owen Stephens.

ghSat Jan 25 15:45:37 UTC 2014

resolve issue2345: solution using cabal's checkForeignDeps

Usually, Cabal performs the external dependencies check after the configuration phase, in the postConf hook. This patch moves this check into the configure section.

co-danMon Jan 20 22:05:52 UTC 2014

resolve issue2209: Automatically detect replace

This patch add the flag --look-for-replaces to amend-record, record and whatsnew commands, to automatically detect possible replaces.

jlnederFri Jan 10 04:20:13 UTC 2014

add hashed-storage 0.5.11

ghFri Jan 10 00:34:02 UTC 2014

resolve issue642: Automatic detection of file renames

jlnederSun Sep 15 23:41:26 UTC 2013