darcs repository web UI and hosting app. This is the main darcsden trunk, which also runs hub.darcs.net. (http://hub.darcs.net)

#106cannot resolve dependencies when trying to build darcsden

When trying to install the dependencies for darcsden, cabal is not able to resolve the dependencies.

First I get a problem with webdriver.

$ cabal install --dependencies-only
Resolving dependencies...
cabal: Could not resolve dependencies:
trying: darcsden-1.1.98 (user goal)
trying: webdriver-0.5.4 (dependency of darcsden-1.1.98)
trying: temporary-1.2.0.3 (dependency of webdriver-0.5.4)
next goal: exceptions (dependency of webdriver-0.5.4)
rejecting: exceptions-0.6.1, 0.6 (conflict: webdriver => exceptions>=0.4 &&
<0.6)
rejecting: exceptions-0.5, 0.4 (conflict: temporary => exceptions>=0.6)
rejecting: exceptions-0.3.3.1, 0.3.3, 0.3.2, 0.3.1, 0.3, 0.2, 0.1.1, 0.1.0.1,
0.1 (conflict: webdriver => exceptions>=0.4 && <0.6)
Dependency tree exhaustively searched.

Note: when using a sandbox, all packages are required to have consistent
dependencies. Try reinstalling/unregistering the offending packages or
recreating the sandbox.
$

After taking out the upper version limit on webdriver, I get the following error:

$ cabal install --dependencies-only
Resolving dependencies...
cabal: Could not resolve dependencies:
trying: darcsden-1.1.98 (user goal)
next goal: pandoc (dependency of darcsden-1.1.98)
rejecting: pandoc-1.12.4.2, 1.12.4 (conflict: aeson==0.6.2.1, pandoc =>
aeson>=0.7 && <0.8)
trying: pandoc-1.12.3.3
trying: yaml-0.8.8.2 (dependency of pandoc-1.12.3.3)
trying: resourcet-1.1.2.2 (dependency of yaml-0.8.8.2)
next goal: http-conduit (dependency of darcsden-1.1.98)
rejecting: http-conduit-2.1.2, 2.1.1, 2.1.0 (conflict: darcsden =>
http-conduit>=2.0 && <2.1)
rejecting: http-conduit-2.0.0.10, 2.0.0.9, 2.0.0.8, 2.0.0.7, 2.0.0.6, 2.0.0.5,
2.0.0.4, 2.0.0.3, 2.0.0.2, 2.0.0.1, 2.0.0 (conflict: resourcet==1.1.2.2,
http-conduit => resourcet>=0.3 && <0.5)
rejecting: http-conduit-1.9.6, 1.9.5.3, 1.9.5.2, 1.9.5.1, 1.9.5, 1.9.4.5,
1.9.4.4, 1.9.4.3, 1.9.4.2, 1.9.4.1, 1.9.4, 1.9.3, 1.9.2.2, 1.9.2.1, 1.9.2,
1.9.1, 1.9.0, 1.8.9, 1.8.8, 1.8.7.1, 1.8.7, 1.8.6.3, 1.8.6.2, 1.8.6.1, 1.8.6,
1.8.5.2, 1.8.5.1, 1.8.5, 1.8.4.5, 1.8.4.4, 1.8.4.3, 1.8.4.2, 1.8.4.1, 1.8.4,
1.8.3, 1.8.2.1, 1.8.2, 1.8.1, 1.8.0, 1.7.0, 1.6.1.2, 1.6.1.1, 1.6.1, 1.6.0.4,
1.6.0.3, 1.6.0.2, 1.6.0.1, 1.6.0, 1.5.0.3, 1.5.0.2, 1.5.0.1, 1.5.0, 1.4.1.10,
1.4.1.9, 1.4.1.8, 1.4.1.7, 1.4.1.6, 1.4.1.5, 1.4.1.4, 1.4.1.3, 1.4.1.2,
1.4.1.1, 1.4.1, 1.4.0.2, 1.4.0.1, 1.4.0, 1.3.0.1, 1.3.0, 1.2.6, 1.2.5, 1.2.4,
1.2.3, 1.2.2, 1.2.1, 1.2.0, 1.1.2.2, 1.1.1, 1.1.0.1, 1.1.0, 1.0.0.1, 1.0.0
(conflict: darcsden => http-conduit>=2.0 && <2.1)
Dependency tree exhaustively searched.

Note: when using a sandbox, all packages are required to have consistent
dependencies. Try reinstalling/unregistering the offending packages or
recreating the sandbox.
$

My version of ghc and cabal is below:

$ ghc --version
The Glorious Glasgow Haskell Compilation System, version 7.6.3
$ cabal --version
cabal-install version 1.20.0.1
using version 1.20.0.0 of the Cabal library 
$

I performed a cabal update before trying to install the dependencies above.