mirror of http://darcs.net/screened (fork of darcs's darcs-screened)  (http://darcs.net/Development/GettingStarted)

drop CarrierType - it can't ever be Rebasing p now

ganeshWed Feb 17 19:26:22 UTC 2016

break out a runJob function

ganeshWed Feb 17 19:26:22 UTC 2016

drop RecontextRebase

ganeshWed Feb 17 19:26:22 UTC 2016

drop NameHack

ganeshWed Feb 17 19:26:22 UTC 2016

inline MaybeInternal module into Named.Wrapped

ganeshWed Feb 17 19:26:02 UTC 2016

make the Rebase import qualified

ganeshWed Feb 17 19:24:39 UTC 2016

sort out Commute/Merge instances

ganeshWed Feb 17 19:16:50 UTC 2016

read rebase patches into RebaseP

ganeshWed Feb 17 19:16:50 UTC 2016

get rid of Rebasing

ganeshWed Feb 17 19:16:50 UTC 2016

stop Convert using Wrapped.patchcontents

ganeshWed Feb 17 19:16:50 UTC 2016

add 'activecontents' to replace 'patchcontents' for use in conflict resolution

The semantics of 'activecontents' are more clearly defined, avoiding any uncertainty over how Suspended patches are treated.

ganeshWed Feb 17 19:16:50 UTC 2016

fix fmapFL_WrappedNamed

ganeshWed Feb 17 19:16:50 UTC 2016

replace MaybeInternal with IsRepoType

ganeshWed Feb 17 19:09:48 UTC 2016

introduce RebaseType

ganeshWed Feb 17 06:52:21 UTC 2016

add RebaseP

ganeshWed Feb 17 06:52:15 UTC 2016

add nullary RepoType

ganeshWed Feb 17 06:51:46 UTC 2016

flip dependency between Named.Wrapped and Rebase.Container

This involves moving a bit of code out of Rebase.Container

ganeshWed Feb 17 06:50:53 UTC 2016

add wrapper type around 'Named'

At this point the wrapper is isomorphic to Named, preparing for a future refactoring where we will introduce a separate constructor to hold rebase internal patches.

ganeshWed Feb 17 06:50:48 UTC 2016

get rid of a couple of trailing newlines

ganeshWed Feb 17 06:41:11 UTC 2016

add versions of simplifyPush[es] for Suspended

It would be nice to use them in Darcs.UI.Commands.Rebase too, but that is currently very much based around manipulating FL (RebaseItem p) directly, so isn't a trivial refactoring.

ganeshWed Feb 17 06:41:11 UTC 2016

move addFixup to Rebase.Container and give it a clearer name

ganeshWed Feb 17 06:41:11 UTC 2016

add Repair instance for Suspended

ganeshTue Feb 16 06:08:57 UTC 2016

Ignore the rebase internal patch when showing dependencies

ganeshMon Feb 15 20:29:16 UTC 2016

Get rid of the need for DummyPatch in Darcs.Patch.Match

ganeshFri Feb 12 23:56:05 UTC 2016

drop re-exports from Darcs.Patch.Rebase

ganeshFri Feb 12 23:56:05 UTC 2016

abstract out checking whether a Named is internal

ganeshFri Feb 12 23:56:05 UTC 2016

simplify instance ShowPatchBasic (RebaseSelect p)

ganeshFri Feb 12 23:56:05 UTC 2016

remove unused executable and testsuite dependencies

ghFri Feb 5 10:06:14 UTC 2016

comment in cabal file workaround

ghThu Feb 4 10:27:12 UTC 2016

group all non-optional build-depends

ghThu Feb 4 10:09:53 UTC 2016